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Bonus Chapter » Making the Internet Work With AutoCAD

utoCAD 2004 contains a set of tools designed to make it easier to use with
the Internet. They range from simple utilities to a wizard that leads you
through the process of publishing AutoCAD drawings on the Web., In this
chapter, we will be taking a brief look at some of these features.

The Communication Center

g In the lower-right corner of your AutoCAD screen is a small icon
w that looks like a satellite dish. Click it. If the Communication
Center has not been set up vet, vou will see a window like the one here.
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The check boxes here are unavailable until you click the text next to the upper
check box and select your country and how often you want to be updated in the
Configuration Settings dialog box (see Figure 15.1). There are four choices for
frequency of update: daily, monthly, weekly, and on demand. At the bottom,
check the Enable Balloon Notification For New Announcements check box to
allow AutoCAD to display a balloon on vour screen when new updates become
available.
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FIGURE 15.1: The Configuration Settings dialog box

Once you've completed and applied your information and choices in the Con-
figuration Settings dialog box, vou return to the Communication Center Wel-
come window. The upper check box is checked, and the text next to the middle
check box is now highlighted, or hot. If you are connected to the Internet and
click this text, your computer will connect to the Autodesk website and down-
load new information. The Communication Center Status window monitors
the downloading process.

Commmmumicaion Cenfer Slatus
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iaetling U labsnd; Lipdafias and Anndurcemants

When the downloading has finished, the Communication Center Welcome
window is displayed again, and the text next to the lower check box is high-
lighted. Click it to display the Channels tab of the Configuration Settings dia-
log box (see Figure 15.2).
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FIGURE 15.2: The Channels tab of the Configuration Settings dialog box

This is where the available channels are listed. Check those on which you want
to be kept up-to-date. Click Apply, and then click OK. Now you will see the Com-
munication Center dialog box in its final, set-up form (see Figure 15.3).
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FIGURE 15.3: The Communication Center dialog box after being set up

The status of AutoCAD is displayed (up-to-date or not), and any relevant new
information is listed under the headings of the other channels you selected. Now
each time you click the Communication Center icon, you will see this dialog box.
When you connect to the Internet, the information in this dialog box is automati-

cally updated.
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Help Menu Internet Features

Help Menu Internet Features

On the Help menu, there is an Online Resources submenu that lists four Inter-
net features.
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If you are connected to the Internet, choosing items on this menu takes you to
various web pages on Autodesk’s website:

» Clicking Product Support takes you to the Autodesk Point A website
and displays the Product Support page (see Figure 15.4).
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FIGURE 15.4: The Autodesk Point A Product Support page
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» Clicking Training takes you to the Authorized Training Centers page
of the Autodesk.com website (see Figure 15.5).
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FIGURE 15.5: The Authorized Training Centers page of the Autodesk.com
website

» Clicking Customization takes you to the AutoCAD section of the
Developer Center (see Figure 15.6). From here you can find out about
other Autodesk products as well.
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FIGURE 15.6: The AutoCAD section of the Autodesk Developer Center

» Clicking Autodesk User Group International takes you to a page
where you can log on and become a member for free.
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You can access two Internet features that work with AutoCAD using the Files
menu—eTransmit and Publish To Web—and you can access one other Internet
feature from the Insert Menu—Hyperlinks.

eTransmit

If you use e-mail, you can attach AutoCAD files to vour messages. eTransmit is a
utility that bundles AutoCAD drawings and their relevant auxiliary files in prepa-
ration for e-mail attachment. It saves you the trouble of identifying and collect-
ing these auxiliary files, and it organizes them according to various options.

To see how eTransmit works, let’s use a file we developed in this book. When
you make a . dwg file the current file, eTransmit will set up the transmission for
this file.

1. Open the Sitelda drawing (see Figure 15.7). This is the drawing of

the site plan with three auxiliary views of the externally referenced
Cabinl2a.dwg file. This Xreferenced file should be included in the
bundle we are sending.

FIGURE 15.7: The Sitelda drawing
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You can access

an alternate view,
the List View, by
dicking the left but-
ton at the top of the
display window on
the Files tab in the
Create Transmittal
dialog box.
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2. Choose File > eTransmit to open the Create Transmittal dialog box
(see Figure 15.8).
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FIGURE 15.8: The Create Transmittal dialog box with the Files tab in front

3. Click the Files tab to bring it to the front. Figure 15.8 (shown earlier)
shows the Tree view. It displays the 2 . dwg files and the 11 associated
files that need to be included in the transmission, in a hierarchical
tree form.

4. Click the General tab to make it active (see Figure 15.9). In the Notes
text box at the top, you can write a message that will be sent with the
transmittal report.
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FIGURE 15.9: The General tab in the Create Transmittal dialog box

5. Open the Type drop-down list. There are three options for the format
in which the set of associated files are grouped and sent. Note the
Password button to the right.

Fioider [sel of fles
Tecit Foider'Sdn 4o 2 I

Each option has its own characteristics.

Folder (set of files) Bundles the files into a folder that you des-
ignate, uncompressed, and saves the folder on your hard disk. You
can then use a file compression utility to create a compressed file
and attach this file to an e-mail. The password option is not avail-
able for this type.

|5-el eliacing sssculab |7 e = ‘ ‘

Self-extracting executable (*.exe) Creates a self-extracting
.exe file titled with the name of the current drawing (such as
Sitelda.exe) and saves it in the folder you designate. When the
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10 Bonus Chapter » Making the Internet Work With AutoCAD

recipient downloads and double-clicks this file, the bundled files
are extracted. The password option is available for this type.

Zip (".zip) Createsa .zip file containing the bundle of files.
When the recipient downloads and double-clicks this file, the
WinZip application is started, and the files can be extracted. The
password option is available.

6. Click the Report tab. It displays the contents, including any text you
entered in the Notes box of the General tab, of a .txt file that accom-
panies the transmittal bundle. Click the General tab again.

7. Below the Type drop-down list is the Location drop-down list and a
Browse button, for determining where the set of files to be transmit-
ted will be saved on your computer. The drop-down list displays loca-
tions of previous transmittals.

8. Below the Location drop-down list are five check boxes for further
options:

Convert Drawings To When checked, activates the Format drop-
down list, which has two options: AutoCAD2000/LT 2000, and
AutoCADZ2004/LT 2004 drawing formats.

Preserve Directory Structure When this box is checked, AutoCAD
creates a set of folders matching those that the files being sent were
in, to be part of the bundle. For Sitel4a.dwg, the folders would
look like Figure 15.10. The . dwg files are in the C:\ProgramFiles\

AutoCAD 2002\Training Data folder. When mﬂ ﬁl& *g
are put in one folder. K

max.book118. .com
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FIGURE 15.10: The folder structure for transmittal of Sitelda
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Remove Paths From Xrefs and Images When this box is checked,
the current paths of accompanying . dwg files or image files that are
attached to the current drawing (or nested) are deleted.

Send E-mail With Transmittal When checked, the transmittal
will be attached to an e-mail.

Make Web Page Files Posts the transmittal to a web page.

9. When all options have been set, click OK. The transmittal is created
and saved in the designated folder on your hard disk.

Publish to Web

Publish To Web is a utility for publishing your AutoCAD drawings on the Webh.
When you choose File = Publish To Web, the Publish To Web Wizard starts.
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A series of screens with helpful descriptions walks vou through the utility's
features. They let you do the following:

> Name the web page, specify its location, and enter a description.

> Select an image type and, depending on the type you choose, size.
One of the three choices is an AutoCAD type, . dwf, which has no size
option.

> Choose from among four format styles, or templates. Your drawings
can be thumbnail sketches or listed by name with a viewing box.

> Choose a color scheme from seven options (Theme).

» Decide whether to include a drag-and-drop tool called i-drop.
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» Choose which drawings to regenerate as they are captured (see Fig-
ure 15.11).
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FIGURE 15.11: The Select Drawings screen of the Publish To Web Wizard

The wizard generates the web page and offers you a preview (see Figure 15.12).
You can click the filenames to see the various drawings and then close the pre-
view and click Post to post the page to a website. You can use the same proce-
dure to edit an existing web page.
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FIGURE 15.12: A previewof a new web page with AutoCAD drawings
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Using Hyperlinks

A hyperlink is a mechanism that links an object in an AutoCAD drawing to some-
thing else. For example, it can link a block in a drawing to an Internet website, to
another drawing, or to a Word document.

Choose Insert > Hyperlink to create a new link. After you select objects, the
Insert Hyperlink dialog box opens. Specify the file or click the Web Page button
to connect to the Internet and find a site to link to. Once a hyperlink has been
created, the object with the link acts like a hot button. When you move the cur-
sor to that object, AutoCAD displays the hyperlink icon and a tool tip.

Select the object, then right-click to bring up a shortcut menu. Select Hyper-
link at the bottom of the menu. A submenu is displayed that includes the website
or the file location of the document that the AutoCAD object is linked to.

| Cuk Skt
Froperties H
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| Cory Hypeink,
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In this example, the word BALCONY in the AutoCAD drawing is linked to the
main Autodesk website, so the website is displayed on the submenu. When you
click it, vou are connected to the website.

Summary

I encourage you to experiment with the Internet tools offered by AutoCAD. Some
of you may be beginners at AutoCAD but guite savvy on the Internet. If so, you
may already know about tools like those described in this chapter. Good luck in

Fl LY
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Are You Experienced?

Now you can...

¥ set up the Communication Center and get live updates
A access the Autodesk and Autodesk Point A websites

¥i send AutoCAD drawings with e-mail through eTransmit
¥i publish an AutoCAD drawing to the Web

¥ link an AutoCAD object in a drawing to a website with a
hyperlink
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